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Overview
* Display Builder replaces OPI Builder (BOY) in CS-Studio

Built on Eclipse plugin framework as both a user interface and IDE
Editor perspective to create user interfaces

Runtime perspective to interact with user interfaces

Backward compatible (mostly), can import .opi files and save as .bob

30+ widget types at this time
* Simple data read/write widgets like gauges and input fields
 Complex interactive widgets like custom graphs or a web browser
e Structural and design widgets like text labels, images, and groups
* Customize widgets for your site using widget style classes
Scripting support for custom behaviors

Integrated with other CS-Studio tools, e.g. data browser
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Examples: SNS Instruments
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CS-Studio
\ " w
(. NS
 Display Builder is a component of the Control System = control system studio

Studio

e (CS-Studio is an extension of the Eclipse IDE
— http://controlsystemstudio.org/
— https://eclipse.org/ide/
* (CS-studio can be downloaded from the location above,
or through one of the site specific download areas

* Like Eclipse IDE, CS-Studio will run on any
Windows/Linux/OSX with a supported version of Java

e This tutorial is based on a redhat virtual machine
image running the SNS version of CS-Studio

eclipse



Getting Around in CS-Studio

On Linux, launch CS-Studio with the “css” command
— Adialog will pop up and ask which workspace to use. For now,
leave it as the default selection
CSS should open up in the default “CS-Studio” Perspective
— If you see a welcome screen, close it using the small ‘X" in the
corner of the panel
All of the sub-windows in Eclipse are called Panels
—  This screen has one open panel: The Navigator
—  Panels can be dragged around and rearranged as you work on a
project
Perspectives define a set layout of panels and controls for a
given type of work
—  Right click on perspective name to select “Reset”
— Display Editor Perspective

*  Open Display Editor perspective with the perspective
selection button

*  We will be in this perspective for the entire tutorial

* Sets up editor area with navigator, outline, and properties
panels arranged around it.

— Display Runtime Perspective
*  We will not need this perspective during the tutorial
*  Does not include file navigator and other tools

* Meant to be open in production once “Top Displays” have
been defined
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Display Editor: Basics

* Focus on function: Edit and Run displays connected to PVs

e Common control system elements should be as easy as 1-2-3:

1. Dragand drop a “Text Update” widget onto your display in the editor
2.  Assign an EPICS process variable (PV) to your widget in the editor
3. Hit “Run” and see your display in the runtime

What you will get for less than 5 minutes effort:
v' PV value as text
v PV severity reflected in border color
v" PV name and value shown in tool-tip
v Indication of “disconnected’ state via a pink border



Walkthrough: My first display

* Create new Display

Select File -> New

This will open a “Select a Wizard” dialog
Choose Display Editor -> New Display

Click Next

Name the file “my_display.bob” and
choose the /CSS container

Click Finish
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My First Display: Add Some Widgets
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My First Display:

A @ v B 1 ' R
H OW tO R u n . Navigator & = a8 *Display 2
St — My Display
There are several ways to test your 1My Display oo —rw —
display in the ru ntime Some Value:  <sim://sine> Some comment. L Q = - My ?|5P|ay
— Hit the Run button on the control bar N Pt :
, . , S |8 oo —
— ORrright click inside the display and . @ O e
”Execute Display” (Wi” also Save) =:| Open Editor Perspective & examples m::ﬁi:zm ‘
— OR Right click on my_display.bob ->
Open With -> Display Runtime e e
Runtime panel will open to the right
side, over the properties panel
— Watch your ramp value count to 10
— The ramp value will show a single solid . . = 0 [ D rropertes | @ Diptay % - o
outline for warning and double outline yy pispiay AT ——
for severe at the high and low end ofits . =~ B Polygon My Display
range ::Oly:nel Some Value: -2.94 a.u. Some comment.
— Click the button to turn the LED on and e AL
off by changing the value of “test” 0 | o oo i
LED Qo 9
LED (Multi State)




Arranging Panels for Display Testing

CS-Studio
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Editor: Using the Widget Palette

Widget palette appears in editor panel whenever a

display file is being edited

Just drag and drop widgets from the palette onto the

display in the editor

Widgets are arranged by section

Graphics are static images

Monitors change in response to changes in a connected PV
(read-only)

Controls make changes to PVs, and may also change in
response to changes in the PV (read and write)

Plots are more complex images based on PV values

Structures are used to make more advanced display
elements, such as groups of widgets or embedded displays

And then some miscellaneous elements...

 Hover the mouse over a widget to see a description
tooltip
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Properties panel allows
editing widget attributes
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Editor: Customizing Widget Propertles
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Editor: Manipulating Widgets
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PV Names and Examples

* ca://some pv name

— EPICS Channel Access PV
* some pv name

— Typically same, since “ca://” is the default
e sim://sine

— Simulated PV. Read online help for details
e loc://x(4)

— Local PV. Read online help for details
* pva://x

— EPICS V4 pvAccess



Editor: Drag and Drop Text

CS-Studio includes drag and drop functionality

Text can be dropped into display
Prompt will ask about Widget type

Exercise: A file full of process variable names

Make a new text file in Eclipse
* File -> New then select General -> File
* Name the file pv_names.txt and select /CSS parent folder

Arrange text file below Display Editor panel
Type some lines of text to be PV names

Drag text from file into display editor, it will give
prompt for widget type

Make a text update widget

What happens when we run with this text update
widget assigned to our unqualified PV name?

The default PV type is channel access (ca://)
This txt update will show the PV disconnected, unless
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Editor: Widget Behaviors

Widget behaviors allow control over more complex functionality
— Later exercises will cover these in more detail

Actions
—  Widgets can have assigned actions
—  Usually for button press

Rules and Scripts

—  Widgets can have arbitrary scripts attached to them that alter widget properties
Rules are a safe way to generate common script actions

Tooltips
—  Set the text that appears when hovering over a widget
Alarm Border
—  Only for widgets that can have a PV assigned to them
—  Disable or enable border for alarm states
Items, Items from...
—  This is used for multi-choice widgets like a combo box

— Togetitems from an enum PV type, assign the PV to the widget and set “Item
from..” to true

Enabled
—  Only for widgets with mouse press functionality (buttons, checkbox, etc)
Other Behaviors...

—  Various widgets have behaviors regarding limits, min/max values, etc

—  Behaviors with “from...” indicate whether to get these values from the connected
PV or not

Behavior

Actions

Rules

Scripts

Tool tip
Alarm Border
Items

Item

Item

Items from ...

Enabled

No action
0 rules
0 scripts
S(pv_name)$(pv_\
true
2
Item O

Item 1

true

true

4)



Access Online Help

Searchable online help is
included

Help -> Help Contents
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1. Overview

The Display Builder is a panel editor and runtime for control system displays.

2. Getting Started

2.1 Display Builder Examples

The Display Builder example files demonstrate many of its widgets and features.

(: CS-Studio
File Edit Search CS-Studio Window Help
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execute a display o — T e (offe ’
— With the Display Builder examples e e —— f: 65 LED (New Workbench Window)
installed, navigate to Display Builder 3 @ st —
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Display Runtime & tamplee s |~
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Runtime: Tooltip & Context Menu

From the main example screen, click “Text

Update” button

Tooltip

Hover over any of the text update fields to see a
tooltip for the widget

PV info for widgets with connected PV
General info for other widgets

Context Menu (right click on any widget)
Get info for a given widget (i) -> debugging help

Reload Display

& Text Update %

100% v & v o

Vg

Formatting options:

Default: [4.76 au. i
@ Text Update_4

Don't show units:

X Process Variable >

[476E0 a.u. | [ Save Snapshot..
[476E0 au. | = Print

L% Send E-Mail..

Decimal w/ 2 digits:
Exponential Notation:

Engineering Notgydfi:

gsffare Number Options: & Send to Logbook.
Decimal: 3.1400 &3 Full-screen

[ Change to Standalone Window

Open Display in editor

Send email (if configured for your site)

Send to Logbook (if configured for your site)
Possibly other functions...

Engineering: 3.1400E0 represents a number 3.5 as
‘ees), minutes and seconds,
Hex: 0x3 E &: Open in Editor
— " Re-load Display e cCialization treats the number as radians
i (HMS): 11:59:38 11:59:38 and maps 2 pi to 24 hours,
while the DMS specialization maps 2 pi to 360 degrees.
Sexagesimal (DMS): 179:54:31 179:54:31 (Try a value of 3.14 or 6.28 to see the effect)



Runtime: Send PV to other CSS Tools

* Display Builder is
integrated with other CS-
Studio tools...

* Probe tool

— Right-click, select Process
Variable -> Probe

e Databrowser

— Right click, select Process
Variable -> Data Browser

=i Main 22 *<Not saved to file> 83 = g
£+ [FMR]@)k =
o
3
T
KX
@
E=
Lo
2
B o
o
LA e e e e e e e e L e e e e e I e e e e e S e TSN [N B e e e m e s e
12:42:20 12:42:30 12:42:40 12:42:50 12:43:00 12:43:10 12:43:20 12:43:30 12:43:40 12:43:50
2017-05-01
&l Text Update 8 100% v | v = O || AZsim//sine 8 Bv = 0

Formatting options:

Default:

ﬁw
® Text Update_5

Don't show units:

Decimal w/ 2 digits:

Process Variable

Exponential Notation:
Engineering Notation: IE lsll Save Snapshot..
& Print..

Compare Number Options [ Send E-Mail...

Decimal: 3 & Send to Logbook.

Engineering: 3 ¢ Full-screen

Hex: o [ Change to Standalone Window
Sexagesimal: 3 = Open in Editor

Sexagesimal (HMS): 1 ¥ Re-load Display

179:54:31 179:54:31

Sexagesimal (DMS):

{5 Copy PV name to clip-board
_E_ERICS PV Tree

f‘ /? Probe

T PVTante

‘p‘é OP}Probe.

¢ QZ, Data Browser |

P EPTESET IS e TTUmUET 3:3,

qours (or degrees), minutes and seco,
2.g. 3:30:00.

The HMS specialization treats the nun
and maps 2 pi to 24 hours,
while the DMS specialization maps 2

(Try avalue of 3.14 or 6.28 to see the .,

>

PV Formula:  sim://sine

Value: 4.755 [MAJOR - HIHI]

Timestamp: ' 2017-05-01 12:43:29.344000000

New Value: |4.755

¢ Data source is read only

Status: Connected



Exercise: Grouping Container

 Using the my_display.bob that we started
earlier, group the LED and boolean button
so that they can be manipulated as a unit.

Under “Structure” in the widget palette, drag
a “Group” widget onto the display

Drag the LED into the group
Drag the boolean button into the group

The group will highlight when widgets are
added, and the outline will reflect the new
structure

Select the group and use the properties
change the name to “Button Group” and the
style to “Title Bar”

Right click and “Execute Display” to see the
group in the runtime and click the button

&= Outline

&) *Display 52

My Display

Some Value:  <sim://sine>
Drag
widgets to

group

|

Some comment.

<sim://framp(1,10,1)>

G'°”P—§—n—ﬂ*
190, 220
0100, 30

A Label

A Label_1

0.0 Text Update
A Label_2

g0 Text-tpdate—+

7% =] Group_1

LED

= Boolean Button

= @
it Scaled Slider

414 Scrollbar

mell Text Entry
¥ Plots
£ DataBrowser
{8 Image
£Z X/Y Plot

Drag
group to

. v Structure
display Haray
{4 Embedded Display
= Group

[ Tabs

¥ Miscellaneous
® Clock
26 Digital Clock

@ Web Browser

D Properties 8| 4 ¥ = O

Widget

Type FEGFoup-

Name TButton Group ) & Display %

; i

Class SDEFAULT i

— —— My Display

°°°°°° Some Value: 2.94 a.u. Some comment.
X Position 70

Y Position 150

Width 230 2.00 a.u.
Height 70

isplay

Visible erE (
Style Title Bar )

Font =

Foreground... [l Text

Backgros O Background

Behavior

Actions No action

Rules 0 rules

Scripts 0 scripts

Tool tip




Exercise: Macros and Containers

* Display Builder supports macros
— Notate as S(macro) or S{macro}
— Can be used for any widget property

— Often used as PV name or partial PV name

* S{pv}
o S{pvprefix}_setpoint

e Utility of this comes from building a display using macros, then making several instances of this
display with different macro definitions
* Macros can be defined at various levels, and are resolved in the following precedence:
—  Preferences
— OpenDisplayAction
— EmbeddedWidget
— DisplayModel
— GroupWidget
*  For the next exercise:
— Make a new display (“sub_display.bob”) using macros for widget properties
— Add two embedded displays to “my_display.bob” with different macro definitions for sub display widgets



Exercise: Macros and Containers

Create a new display file
—  File -> New, then Display Builder -> New Display
— Name it “sub_display.bob” in folder /CSS

—  Delete all widgets except for the title label, change it from
“My Display” to “Mini Display”
e Delete widgets using backspace (ctrl-delete on OSX)

[ Properties & = 0

File Edi

Y

- v

TIP: To change the text that appears on the/, — -
tab at the top of the display in the editor, <’§’;
click somewhere on the background to get

the properties panel for the display, then
change the name to “Sub Display”

display

| Sub Display

S _—
s —DEFAULT e

|I | | |

B | L CS-Studio

i Display Editor | i Display Runti

e  Set label text in the “Text” field of properties Seer B 7 2 ;AD - l;. ; o ~TTT@Caige E BA il S
. . co el B S ini Display o~
Add a scaled slider from the controls section of the . o D b o ;
—————————————————————————————————————————— ] ) LED (Multi State) a B P
palette S & CSss Ci‘,m’)‘m H”:.I ....... .: =i Linear Meter :::ne -+Sca|e\ddShc
—  set “PV Name”=${pv} B project D!_O____m___ff___Bf__f_o___;_fo___i__f___gf‘b S meter = ==
—  Under behaviors, set: =y dsplay bob powressgar (@vvme s D)
e “Limits from...”=false : 34 Tank -
. . . _ . 0.0 Tex! date Y Position 60
Add a linear meter from the monitors section of the - © Diplay Buider —— T
pa Iette - S 2 v Controls v || Height 69
8% Outline R = T B N - Display
- Set “PV Name”=${pv} A Label ;.Dls.m:;. - SIUb o ® mablhd 2 || visivee tue | v
. < . Ini Display Horizontal tue | v
— o it Scaled Slider
Under beha!wors, set: e s Foreground... 1 [
e “Limits from...”=false Backgroun... [] [ Bac.
L ”U nit from PV"=fa|Se Transparent | true v
N . . . Font Default
Right click and “Execute Display” to save the file and ' — sowsoe [we |8
see the sub display in the runtime _ : _ S G ' stowmino.. [tue iz
Widgets will show disconnected PV when Relcpeed| 40
we execute the sub display without 5| >enteFormet v

macros defined

training




Exercise: Macros and Containers

Open “my_display.bob” in the editor

Add the Sub Display:

— Drag an “Embedded Display” from the palette
— With the embedded display widget selected:

Set the “Resize Behavior” to “Size content to fit
widget”
Click the “...” button next to the File property

Navigate to /CSS/sub_display.bob in the file
selection dialog

Click OK

Oh no! The sub display is very small inside the
embedded display widget

— Each display has a width and height in pixels

— We will need to set the sub display size
boundaries more tightly around the widgets

[ R O S B | g g _Fl
o Thisisn’t P
‘ right... i
D!
W TIITIrir WL ITIITIIrT b
eeeeeeeee
eeeeeeeeeeeeeee
& <
B CssS
proj
L

ccccccccc

aaaaaaaaaaa

nnnnnnnnnnn

cccccc

uuuuuu
AAAAAAA
RRRRR
SSSSSSS
ooooooo

tudio isplay Edi
[ Properties b3
Widg:
Typ {E embedded
Name | Embedded Display_1
ssssssssssss
bbbbbbbbbbbbbbbbb
MMMMMM 0
OOOOOOOOOOOO
wwwwwwwww
wwwww
|||||
________ it ==
4 e
ize B tent to fit wi b :
roup name —

aaaaaaaa
OOOOOO

ssssssss

nnnnnnnn




Exercise: Macros and Containers

> Open ”SU b_display- bOb” in the FO| =@ B W E| ¢S [ % | CS-Studio = Display Editor ] Display Runtime

d N & *Display |l Sub Display X = B | [OProperties 8 = B
T oo T - Vauyc R
e tOr Mini Displa ! v
I play [ LED —
! LED (Multi State) St
ulti ate

* (Click on the background to get the = < = | '

e Ry RO S R U AT e g linearMeter Name Sub Display

. . EH Meter Class DEFAULT
display properties panel e |, n

aaaaa
ETable | |/ position

e Change width and height untilthe L

red outline is tight around the 1‘ |y [ffeee [0 N

W Height 220
= N

& Display | &/ Sub Display &

widgets ST T
* Returnto “my_display.bob”
— Right click -> “Reload Display”

Reloading display will pull

& Display 2 | & Sub Display in the changes from the = O |(|E Properties % > =
My Display sub display o widg
L @& Arc Type display
Some Value:  <sim://sine> Some comment. @ Ellipse Name Display
Mini Display A Label Class DEFAULT
<sim:/framp(1,10,1)> WWOLWW  HIGH HHI @) Picture Macros 8]
B Pol Position
olyg
2 X Position 0
[ —5000] Polyline _
O 0 ot Y Position 0
1T —— . [ Rectang|l
Width 800

oooooooo



Exercise: Macros and Containers

F O = es® | A WRMEWHE|YS

® | CS-Studio | Display Editor| & Display Runtime

* Add a second embedded display widget - - o fan| 5
below the first B 2 -
— Set the file to “sub_display.bob” S I D =z
— Set resize behavior to “Size content to fit |
widget” . e
Mini Display Y Height 160

» Select the top embedded display: P e

LED (Multi State)

@ Ellipse Name Embedded Display_1

<1 Polyline

ooooooo

Resize Beh... | Size content to fit widget | ¥
[ E— ) o Line{ x

— Click the “Macros” property button —— o =

= prog Enter macros

— Enter a macro with name “pv” and value =

“loc://testl D L T
. My Display
* Select the bottom embedded display
— Click “Macros” ] e || Thesliderin the top mini

display will change the testl

— Enter a macro with name ”pV" and value — — ‘ local variable, and move the

“sim://ramp(1,10,1) bar in that display

* Right click and “Execute Display”
Ramp pv is read only, so —m e
the slider in the bottom T T

display is greyed out




] Display 32| (=] Sub Display = O ||d Properties % m v =8

My Displa; o 0
[ ] [ ] y play LED (Multi State) Type [ action_button
[ ] Some Value: | <simdlsines o Gomme . o Linear Meter Name Action Button
L = Meter i DEFAUET —
° Mini Display
o

=0 Progress Bar

<sim:/iramp(1,10,1)>

Testl = 20 7““5>
=

[ Table

= e
Bution Group 34 Tank ext Sactions)
) 0.0 Text Update Position
enu Buttons =~ =
0 - o ~ Controls Y Position 250
dmesu:z&m‘p T - - -
D', ,,,,,, o h Actions

Configure actions which open displays, write PVs etc

Adq abr|1 action button to change the value of the testl - e "
variable

v ' & Open Display.

B : r\: Iest1 Sckground
— Drag an action button from the controls widget palette to o= oo f“ '
the display o | o
— Click the Actions property button to open Actions dialog M oo |
— Use the “Add” dropdown to select “Write PV” e =
— Enter: s s s e :
* Description: Testl = 20 sy | mon e o
* PV Name: loc://testl );2
*  Value: 20 — o
Menu buttons are action buttons with multiple actions et o
— Drag another action button to the display s —— s W o
—  Click the Actions property button to open Actions dialog ] el —
— Use “Add” to add two actions, as above, where one action minalel R R
sets testl to 50, and one sets testl to 75 —
— Set the “Text” widget property to “Set Test1 Value” T
Right click and “Execute Display”
— Use the buttons to set the value in the top mini display




Exercise: Make a
widget class file

. Widget classes provide support for creating a
standardized style for displays

. Design the widget properties once, in a class definition
file, then use them many times

. Define a new class file:

Create a new display file, File -> New, then Display Editor -
> New Display

For the file name, enter “my_classes.bcf”
The .bcf extension indicates a class file

The file icon in the navigator will reflect that this is a class
file type

. Override the default TITLE class

Select the title “My Display”

The properties panel in the .bcf file editor works
differently than in the .bob file editor

Checkboxes indicate which properties are set by the class
Set the widget name to “TITLE”

Change the “Foreground” property to a light yellow color
Change the “Transparent” property to false

Check the box next to the “Background” property, then
set it to a dark grey color

. Save the file “my_classes.bcf”

Display File

Creates a new *.bob file for the display editor.

Container: /CSS Browse...
File nau{{my_classes‘bcf‘ Wldget name in the CIaSS
R— editor is the class name
for this set of widget
% Navigator & = O |/iC My Classes % | Display propertles /
" n @ " < |5 A~ —
R =iy Display @ Arc =
- B-€SS d - Widget
Some Value:  <sim://sine> Some| | | L®@.Ellipse Type Z o
my_classes.bcf A Label Name (Timie
| & my_display.bob ) Picture Text il
[E pv_names.txt B Polygon Position
& sub_display.bob <1 Polyline X Position viio
|% & Display Builder = Rectangle Ro=to BRI 0
| v v Monitors Width
+ = examples
I Byte Monitor Height
@ Gauge Display
LED Visible
LED (Multi State) i e RESa—

= Linear Meter

& Meter

&0 Progress Bar

£ Table
3a Tank

0.0 Text Update

Foreground... |V/|[] | RGB...
Backgroun... v/ [l | Hea...

Transparent |V/|| false v

NN —— —

Horrzontat—
Vertical Ali...

Rotation

1 Thermometer Auto Size
Wi fords
Check boxes only appear /‘{""yz
& Outline %2 = @ [P in class file editor. Check “Jf" 23':5
ANIEE a property to have the Scripts
e e class define that property Tool tp

A Label 2 T Radio BULto!

2 *t Scaled Slider




Exercise: Make a
widget class file

e Tell CS-Studio to use your class file

Open preferences: Edit -> Preferences
Navigate to CSS Applications -> Display -
> Display Builder

Find the line “Widget Class Files”

Add your class file to the end of the list

* Separate files with semi-colons
* Use the path /CSS/my_classes.bcf

 Update your display to see changes

Open “mydisplay.bob” in the editor

Select the top label that says “My
Display”, make sure the class is set to
“TITLE”

Right click and select “Re-load Widget
Classes”

The properties of the widget change to
match the class style

Preferences

Display Builder

’ =/ CSS Applications |After changes, a restart is required

\ Alarm idget Class Files: platform:/plugin/org.csstudio.display. builder. model/examples/class¢4Bef:/CS S/my_classes.be] )
Debugging N— — <
olor File: platform:/plugin/org.csstudio. display. builder. model/examples/color.def
Diagnostics
bient ont File: platform:/plugin/org.csstudio. display. builder.model/examples/font. def
isplay
BOY lython Path:

File Read Timeout [ms]: | 10000

—

et ) o e hes e e Rt ==c 1| 60
PACE

PV Factory: vtype.pv

<display><name>Main</name><file>/Display Builder/01_main.bob</

Editors

%. Navigator 5 = B |[iEMyClasses |&Display X
e - | ~ v Graphics
=R B S - P -
D . si.iy Display ©A
BCss = ==
Some Value:  <sim://sine> Some S Flpse
C my_classes.bcf A Label
B8 my_display.bob @ Picture
- <sim:/framp(1,10,
[5 pv_names.txt & Polygon
@: sub_display.bob < Polyline
*| & Display Builder o Qo = Rectangle
¥ Monitors

+ & examples
mm Byte Monitor

@ Gauge
J LED

Testl =20

SetTestlValue ~
i Linear Meter
& Meter
© Execute Display 0 Progress Bar
£ Replace with > f Table

5 Rezload-Display: 34 Tank

. \
4" Re-load Widget Classes ) 0.0 Text Update

& OperEditorPerspactive

¥ Controls

[ Action Button

8= Outline % = @ | G EEEE NN RN
= W CheckBox
A Label k ) Combo B
0mbo Box
A Label 1
0.0 Text Update (7 File Selector
A Label 2 @ Radio Button

0.0 Text Update 1

LED (Multi State)

1 Thermometer

~» Boolean Button

it Scaled Slider

O | D Properties = 0
~ oo
Widget
Type A label
| Name: w=tabel
& Class TITLE. Q)
“Text MFDisr | .
Position
X Position C
Y Position C
Width 550
Height 31
Display
Visible true v
| Font. C__Headerl
”(Foreground.. C
Backgroun... C[H
Transparent C J
e
Vertical Ali.... Top v
Rotation 0 degret | v
Auto Size false v
Wrap Words true v
Behavior
Actions No action
Rules 0 rules
Scripts 0 scripts
Tool tip



Exercise: Widget Classes

e (lass files

— Can override classes or define entirely new ones
* One could design a “BLUE LED” in a class file

* Once the .bcf class file is loaded, “BLUE LED” will appear in the class dropdown
for LEDs in the display editor for .bob files

— Are resolved in the order they are listed

* You could have a “master.bcf”, then override certain settings in another file,
“control_room1.bcf”

* C(Classes
— Are applied to widgets when CS-Studio starts up
— Are applied to widgets when the display is reloaded
— Are applied to widgets when the widget classes are reloaded



Exercise: Rules

File Edit Run CS-Studio Window Help

A & 3 ] £0] » &2 & | C Cs-Studio =i Display Editor
. Navigator & = 8 (C My Classes &i Display & = B |DProperties X| 4 ¥ = O
Bllimy Display ~ Graphics ~ || widget
1 & Arc Type OJaction_button
=ess Some Value:  <sim://sine> Some comment. @ Ellipse Name Action Button
€ my_classes.bcf [Mini Display A Label Class DEFAULT
B8 my_display.bob <sim://ramp(1,10,1)> y " @ picture Actions Testl = 20
B) pv_names.txt r— MuPolyaon PV Name
Button Group Text S(actions)
& sub_display.bob [—11 1) <4 Polyline
1 = Rectana Position
. ectangle
& Display Builder — X postion -
. ~ Monitors
|7 & examples 0_____ m o m Byte Monitor Y Position 250
)
dI mE'!r_““efu =_2ﬂmp [Mini Display @ Gauge Width 150
o b o _ - LED) Height 40
Rules x Dispiey)
Visible true
Edit rules for widget: action_button Action Button Font Default
E b || Foreground... Il Text

1
| Disappear ﬂ
|

8= outline &
LED

< Bool

&4 Embeg
(&4 Embe

C Action

/

B Copy PV Name Trigger
% Remove loc://testl v/

U Up

£ Down

B Show Script

< Add

Remove
& Up

< Down

Value as Expressiof (& Property ID: ) )!
B \ [s2clrsy visible, [visible=true] Z))

Boolean Expr...

Value

% Add Eﬁ?i

Gl

0 == 20 ",

v false - Remove | oY
 Up

<> Down

a— - _

Backgroun... [] | ButtonBackr...

B
Rules
Scrpts
Tool tip
Enabled

i Oscripts =

$(actions)

true

—

Rules are a guided way to safely
generate scripts tied to widgets

Scripts generally use some type of
internal logic to determine a widget
property

Exercise: Make a button invisible when

it is not needed

Open the “my_display.bob”
Select the action button “Test1=20"
Click the “Rules” property button to
open the Rules definition dialog
Click “Add” next to “Rule Name”

* Set rule name to “Disappear”
Use the Property ID dropdown

* Select “visible”
Click “Add” next to “PV Name”

e Enter “loc://test1”

* Leave the trigger checkbox checked

Click “Add” next to “Boolean
Expression”

* Enter “pv0 == 20"

* Setvalue to “false”

Click OK



&l Display 8 100% v | & 4

My Display

Some Value:  -0.00 au. Some comment.

Button appears
when this value is

g sovas L — not 20
. . o dm o m s sw T % s o TD‘SP\WH —
Exercise: Rules e
. Some Value:  -0.00 a.u. Some comment.
. . o 0 . —
 Tosee therulein action, right click on the display S
and “Execute Display” : -
— Push the “Test1=20" button
— The button will disappear until you change the value 5
to something other than 20 using the other button S s B s

or the slider

*  What was going on with the pv0 in the boolean sess e

AN RS AlMy Display

expression? What does this rule mean?
- In the Rules dia]og' select “Show Script” to see the Bl p_names.txt from org.csstudio.display. builder.runtime.script import PVUil
python Scri pt that ru ns for this button :: Elrsoecgzsy\g?rt‘ﬁg‘feoiétﬁxcgn\o/ghd variable names in an expression:
. action utton Action Button w pvo 0
— Each PV that we enter can be accessed using its el roles Tor widgets acton button Acton Button | | 42 e
index' Sta rting at O Disappear e Reme o+ dd ## gVLegacySeVO [DEPRECATED]
— If we use the “pv0” accessor, that will return a By || T e
numeric (float) value for the Ot pv in our pv list for RS e avproperyvattuisve:, Faie
this rule ->loc://testl IL"DO:n widget setPropertyValue(visible’, True)

— We could alternatively use “pvStr0” to access this S e,
pV’s string value, or “pvSev0” to get its severity status Z

— Since we selected the “visible” property from the
dropdown, the rule generates the script to change
this value

— Try adding and changing rules and pvs to look at
different script outcomes

Cancel




Scripting...

* As seen in rules, widgets can have scripts tied
to them

* Scripting behavior is more advanced topic
* See Help and examples to get started scripting

e Use Scripts widget property to attach Python
or JavaScript



Runtime Perspective Configuration

* As mentioned earlier, there is a .
“Display Runtime” perspective thatis .
meant to be used in production | oo s e

Widget Class Files platform:/plugin/org.csstudio.display.builder.model/examples/classes.bcf;/CSS/my_classes.bcf
[ ] C f. h IIT D. | ” .l bl Debugging Color Fils latform:/plugin/ tudio.display.build del/ les/color.def
olor File: platform:/plugin/org.csstudio.display.builder.model/examples/color.def
ontigure the " lop Displays™ available Disgnostics
. . . Font File: platform:/plugin/org.csstudio.display.builder.model/examples/font.def
In runtime perspective .
Y BOY Jython Path:
— Select Edit -> Preferences File Read Tmeaut sl | 10000
EDM20OPI Conver ter

URL cache Timeout [sec]: 60

— Navigate to CSS Applications -> Display ->

Editors

. .
D I S p I ay B u I | d e r <display><name>Main</name><file>/Display Builder/01_main.bob</

Management file></display>; <"

« . ”
— Locate the Top D|Sp|ays area Others A TR am e e MR

Test

— Copy/paste the XML for the existing top 2 e T
display o uries

— Separate with a semicolon S
— Change the “name” to Tutorial

— Change the “file” to /CSS/my_display.bob

PV Factory: vtype.pv



cs-stdio Click to select o x

File Edit Source Refactoring Run CS-Studio Window Help perspeCtlve

Runtime Perspective |- I o T
Recent Files... NS \

_ T s 54Ma' el bl
* Open the “Display Runtime” | w¢_
perspective in CS-Studio L o
* Open your display by selecting  |*. " R

|

File -> Top Displays -> Tutorial & ogi

* Top Displays can also be -
. Switch Workspace... —
accessed with the toolbar

Restart CS-Studio

g Import...
& Export... [E— 1]
File Edit Source Refactoring Ru Exit | T

Navigator, editor toolbar
items, outline, and
properties do not appear in
Runtime Perspective.

This arrangement is meant
for production deployment

& Tutorial

&/ Display &2

training




Backward Compatibility: OPI Files

e Display Editor can be used to import .OPI files
— Right click on .opi and select Open With -> Display Editor
— Most widgets will work, screens need to be checked
— Scripts will need to be updated

 When the file is saved from display editor, it will save in new .bob
format
 Can maintain both files
— Will use the .bob file if both exist

— Scripts can check if they are running in BOY or Display Builder and take
different actions depending on runtime environment

e See examples -> script_util -> portable.py



For more information...

* CS-Studio is an open source ( " S\
collaborative project control system studic

* http://controlsystemstudio.org/

wuung“;"”ﬁS“Né &m BROOKHRVEN

FRIB




